首页  |  知识库  |  资源下载  |  在线工具  |  A-Z  •  JAR  •  名词查         

关于“java.lang.UnsupportedClassVersionError: io/undertow/server/HttpHandler : Unsupported major.minor version 51.0”异常错误问题

标签:UnsupportedClassVersionError,Unsupported major.minor version 51.0,编译版本错误,不兼容     发布时间:2018-05-06   

一、异常描述

eclipse运行测试类报"java.lang.UnsupportedClassVersionError: io/undertow/server/HttpHandler : Unsupported major.minor version 51.0"异常错误,详情日志如下

java.lang.UnsupportedClassVersionError: io/undertow/server/HttpHandler : Unsupported major.minor version 51.0@b@	at java.lang.ClassLoader.defineClass1(Native Method)@b@	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)@b@	at java.lang.ClassLoader.defineClass(ClassLoader.java:615)@b@	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)@b@	at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)@b@	at java.net.URLClassLoader.access$000(URLClassLoader.java:58)@b@	at java.net.URLClassLoader$1.run(URLClassLoader.java:197)@b@	at java.security.AccessController.doPrivileged(Native Method)@b@	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)@b@	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)@b@	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)@b@	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)@b@Exception in thread "main"

二、解决方法

项目中jdk1.6版本问题造成的,需改为>1.6及以上(如1.7、1.8版本),具体可以操作参考其他文章的第二部分(二、解决办法)